[Scummvm-tracker] [ScummVM] #9701: WINDOWS: Flow of taking screenshots on Windows is broken

Ori Avtalion trac at scummvm.org
Tue Feb 21 19:26:37 CET 2017


#9701: WINDOWS: Flow of taking screenshots on Windows is broken
--------------------------+-----------------------
  Reporter:  salty-horse  |      Owner:  (none)
      Type:  defect       |     Status:  new
  Priority:  normal       |  Component:  --Other--
Resolution:               |   Keywords:
      Game:               |
--------------------------+-----------------------
Description changed by salty-horse:

Old description:

> When installing ScummVM with Windows installer, taking screenshots with
> alt+s always fails silently.
>
> ScummVM's Windows installer installs the program in %PROGRAMFILES%, as it
> should. This directory requires Administrator permissions, which the
> installer requests.
>
> The installer also creates shortcuts to run ScummVM. These set the
> current directory to the installation dir: %PROGRAMFILES%\ScummVM.
>
> Since ScummVM is run without Administrator permissions (which is good),
> and alt+s tries to save screenshots in the current directory, nothing
> happens.
>
> I propose the following:
> 1) Screenshots should be saved in a user-owned directory. I think
> "%USERPROFILE%\My Pictures" is the common place for those. Alternatively,
> we can use the directory we already create for save games and
> configuration: %APPDATA$\ScummmVM\Screenshots
>
> 2) When alt+s fails to save the screenshot, it should say something.
> Maybe it should pop up a message using the GUI, or maybe it should write
> a line to the debug console.
>
> Maybe it already prints an error to stdout, but on Windows 9 I got no
> console even when running the regular ScummVM shortcut (the one that
> didn't have "(no console)" in its name). Separate bug?
>
> 3) If ScummVM has other non-debugging files it saves to the current
> directory (that is, files that regular users are expected to create
> without technical knowledge) we should redirect those to the %APPDATA%
> dir, if possible.
>
> 4) The README doesn't mention where screenshots are saved to at all.

New description:

 When installing ScummVM with Windows installer, taking screenshots with
 alt+s always fails silently.

 ScummVM's Windows installer installs the program in %PROGRAMFILES%, as it
 should. This directory requires Administrator permissions, which the
 installer requests.

 The installer also creates shortcuts to run ScummVM. These set the current
 directory to the installation dir: %PROGRAMFILES%\ScummVM.

 Since ScummVM is run without Administrator permissions (which is good),
 and alt+s tries to save screenshots in the current directory, nothing
 happens.

 I propose the following:
 1) Screenshots should be saved in a user-owned directory. I think
 "%USERPROFILE%\My Pictures" is the common place for those. Alternatively,
 we can use the directory we already create for save games and
 configuration: %APPDATA%\ScummVM\Screenshots

 2) When alt+s fails to save the screenshot, it should say something.
 Maybe it should pop up a message using the GUI, or maybe it should write a
 line to the debug console.

 Maybe it already prints an error to stdout, but on Windows 9 I got no
 console even when running the regular ScummVM shortcut (the one that
 didn't have "(no console)" in its name). Separate bug?

 3) If ScummVM has other non-debugging files it saves to the current
 directory (that is, files that regular users are expected to create
 without technical knowledge) we should redirect those to the %APPDATA%
 dir, if possible.

 4) The README doesn't mention where screenshots are saved to at all.

--

--
Ticket URL: <https://bugs.scummvm.org/ticket/9701#comment:2>
ScummVM <https://bugs.scummvm.org>
ScummVM


More information about the Scummvm-tracker mailing list