[Scummvm-devel] Re: opcode names (Was: CVS: scummv m/scumm intern.h,2.117,2.118 )

Max Horn max at quendi.de
Mon Nov 10 09:48:05 CET 2003


[...]
> BTW if you don't like "if" instead "jump" than all rest conditions 
> opcodes
> should be changed: isLess, isGreater, isLessEqual, isGreaterEqual,
> isEqual, isNotEqual to jumpIfLess, ....
>
Yes, I agree with that. These opcode names can be very confusing if you 
don't look at the implementation. So I'd indeed prefer these names:
jumpIfTrue
jumpIfFalse
jumpIfEqual
jumpIfLess
...


Cheers,

Max





More information about the Scummvm-devel mailing list