[Scummvm-devel] Unifying data loading, saving and printing (SCUMM, Tinsel & Cine, maybe others?)
lordhoto at gmail.com
Sun Aug 3 00:19:35 CEST 2008
On Saturday 02 August 2008 23:50:43 Max Horn wrote:
> [...] in the approach we chose in Tinsel ...
Just took a look at the Discworld Serializer code, looks really nice especially the VersionedSerializer TODO entry. I personally think that syncAsFoo should be renamed to serializeFoo though. Also I would propose instead of those BE/LE member functions to change the Serializer to accept an SeekableSubReadStreamEndian or similar. For example in Kyra I am using unlike the original savegames, which used LE, BE for saving. Thus to share as much as possible loading code (we leave out some unused data) I'm using SeekableSubReadStreamEndian to read the data.
Just my two cents though :-)
More information about the Scummvm-devel