[Scummvm-devel] [Scummvm-cvs-logs] SF.net SVN: scummvm:[42244] scummvm/branches/gsoc2009-draci/engines/draci

Robert Špalek rspalek at gmail.com
Tue Jul 7 23:56:26 CEST 2009


On Tue, Jul 7, 2009 at 2:18 PM, <dkasak13 at users.sourceforge.net> wrote:

> Revision: 42244
>          http://scummvm.svn.sourceforge.net/scummvm/?rev=42244&view=rev
> Author:   dkasak13
> Date:     2009-07-07 21:18:28 +0000 (Tue, 07 Jul 2009)
>
> Log Message:
> -----------
> * From Game::GameObject removed the following _idxSeq, _numSeq, _animObj,
> _seqTab (not used anymore), added Common::Array<int> _anims.
> * Handled cylic animations properly
> * Handled the Z coordinate properly
>
> Modified Paths:
> --------------
>    scummvm/branches/gsoc2009-draci/engines/draci/game.cpp
>    scummvm/branches/gsoc2009-draci/engines/draci/game.h
>    scummvm/branches/gsoc2009-draci/engines/draci/script.cpp
>
> Modified: scummvm/branches/gsoc2009-draci/engines/draci/game.cpp
> ===================================================================
> --- scummvm/branches/gsoc2009-draci/engines/draci/game.cpp      2009-07-07
> 21:11:36 UTC (rev 42243)
> +++ scummvm/branches/gsoc2009-draci/engines/draci/game.cpp      2009-07-07
> 21:18:28 UTC (rev 42244)
> @@ -211,10 +211,10 @@
>        // FIXME: handle these properly
>        animationReader.readByte(); // Memory logic field, not used
>        animationReader.readByte(); // Disable erasing field, not used
> -       animationReader.readByte(); // Cyclic field, not used
> +       bool cyclic = animationReader.readByte(); // Cyclic field, not used


remove "not used" from the comment


> Modified: scummvm/branches/gsoc2009-draci/engines/draci/script.cpp
> ===================================================================
> --- scummvm/branches/gsoc2009-draci/engines/draci/script.cpp    2009-07-07
> 21:11:36 UTC (rev 42243)
> +++ scummvm/branches/gsoc2009-draci/engines/draci/script.cpp    2009-07-07
> 21:18:28 UTC (rev 42244)
> @@ -226,7 +226,8 @@
>
>        GameObject *obj = _vm->_game->getObject(objID);
>
> -       obj->_seqTab[animID - obj->_idxSeq] =
> _vm->_game->loadAnimation(animID);
> +       _vm->_game->loadAnimation(animID, obj->_priority);


rename _priority to _z or something.  priority was our old player's name and
should be abandoned. similarly, in other modules, where we used "mask", use
overlay or any better name you could come up with.

-- 
Robert Špalek <rspalek at gmail.com>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.scummvm.org/pipermail/scummvm-devel/attachments/20090707/86eafb5e/attachment.html>


More information about the Scummvm-devel mailing list