[ scummvm-Bugs-3175941 ] Android ScummVM

SourceForge.net noreply at sourceforge.net
Tue Feb 8 23:50:07 CET 2011

Bugs item #3175941, was opened at 2011-02-09 00:50
Message generated for change (Tracker Item Submitted) made by jwrath
You can respond by visiting: 

Please note that this message will contain a full copy of the comment thread,
including the initial issue submission, for this request,
not just the latest update.
Category: Graphics
Group: All Games
Status: Open
Resolution: None
Priority: 5
Private: No
Submitted By: Mars (jwrath)
Assigned to: Nobody/Anonymous (nobody)
Summary: Android ScummVM

Initial Comment:
I've made a similar topic in ScummVM forum, but I was told to report this here.

I have a Samsung Galaxy 3 cell phone with Android OS. 
I've installed ScummVM, but there are several problems with supported games, as well as the main control screen.

The letters on the main screen don't show very well. They're like in low resolution, sometimes I can't make out what it says.
Quality only improves if I choose Linux engine from the options.

Next, there are issues with several games. Until now I've tried "Full Throttle" and "The Dig". 
In Full Throttle the intro video, plays like it's zoomed in and I can't see the subtitles properly. When it gets me to gameplay, everything seems fine, but I when I make my first move and wants to change from game play to video mode (for example, the scene where I interact with the bike for the fist time, and plays that short video to show that Ben doesn't have the key for his bike) the entire screen goes to the lower right part. I try to pull the screen with my finger but to it's correct position, but when I release it goes back down-right.
I've already tried several combinations in the main screen (aspect ratio correction, different engines) but no luck. The game remains zoomed in.

Then there is The Dig. The intro movie plays perfectly, with the correct aspect ratio, subtitles are shown great. However when the game starts the screen is moved to the lower right.
I also noticed that the zoom ability my cell phone provides (the one that if you touch two fingers diagonally, it zooms the picture) was enabled during gameplay. Probably that's the reason the screen goes down-right and of course the aspect ratio doesn't remain active during gameplay.


You can respond by visiting: 

More information about the Scummvm-tracker mailing list