[Scummvm-devel] scummvm-tools package?

Max Horn max at quendi.de
Tue Dec 21 15:28:04 CET 2004

My two cents on this:

1) We should rename "extract" to "compress_sou" (or another name, if 
somebody can come up with something better)

2) I'd like to move the "convbdf" and "md5table" to another place (and 
also md5.txt). Two suggestions cropped up on IRC:
   (a) a new CVS module "devtools"
   (b) a new subdirectory "tools" inside the "scummvm" module
Some people prefer (a), considering it to be cleaner. OTOH (b) would 
allow integrating those tools into the build chain: when you do a 
"make", then AUTHORS, scumm/scumm-md5.h,  simon/simon-md5.h, about.cpp 
could be automaticall (re)generated.
Personally I can live with either approach.

3) We have four extraction tools: kyra_unpak, rescumm, 
loom_tg16_extract, mm_nes_extract. If I understand correctly, neither 
is useful to end users with 0.7.0 (rescumm used to be useful, but with 
the new code in 0.7.0, no end user should require it anymore, I hope). 
So we might want to move those along with the other dev tools.

4) We have the following "compression" tools:
    extract, queenrebuild, simon2mp3, sword1mp3, sword2mp3, compress_san
I think those names are somewhat non-descript and incoherent (consider 
sword2mp3, which allows OGG and FLAC output). How about renaming them 
all to match a single pattern? One suggestion:
Maybe that's a bad idea; or maybe the idea is good, but those names are 
bad: this is merely meant to provoke thoughts, I am happy to hear your 
constructive criticism :-).

5) I am not sure about "simon1decr", is that used by end users? If so, 
I assume it falls under my point 4), too.

6) The de* tools are a bit controversial: while they are mostly used by 
developers, I guess, at least some end users might find them handy, 
too. So I guess for now we should just keep them in tools, right?



More information about the Scummvm-devel mailing list